CTech_GoogleAPI

Google Email Settings API

| October 2, 2019

As some of you may already know, Google’s Email Settings API will be discontinued on October 16th, 2019 and as a Google G-Suite Driver customer, it is imperative to update the Driver prior to the sunset date.  

In G-Suite driver versions prior to 4.2, the EmailSettings API was activated to provide management of these features of user’s accounts:

  • Labels
  • Delegates
  • Signature
  • IMAP Settings
  • POP Settings
  • Forwarding
  • SendAs
  • Language

While these settings attributes may not be in use in your environment, the G-Suite driver opens a connection to the EmailSettings API service during driver startup.  When Google turns off the EmailSettings API, it is very likely that our driver will cease to operate.  We are not yet certain how Google will shut down the API.  It might be a soft shutdown or they may push it out a little further, but we need to plan for a hard shutdown to the API.    

The Concensus G-Suite driver has been migrated off of the EmailSettings API to the Gmail API as directed by Google. Concensus G-Suite driver version 4.2.0.0 or later no longer uses or calls the EmailSettings API.  

The updated G-Suite driver, documentation, and OAuth update guides may be found here: https://concensus.jira.com/wiki/spaces/GADD/overview

If you are currently a Primary Support (PSE) or Hosted Customer, you will be contacted by the engineer to schedule the update.  If you have a support contract (retainer) we ask that you enter a ticket ASAP to request an update.  If you do not have a support contract and you would like for Concensus to do the upgrade for your organization, you will need to purchase a Retainer contract to cover the support.  If you’d prefer to perform the update yourself, please visit the documentation in the link above.    

If you have any questions, please contact Jaime Lowther.

Speak With The Experts

  • This field is for validation purposes and should be left unchanged.